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Introduction
We discussed several ways of creating publications in the Publisher 2000: Introduction (dwb03) document,
including starting with blank - but preformatted - pages, or using the PageWizard to create a publication with
objects and frames already on the page.  We learned that these objects and the frames that encompassed them
came in different flavors (text frames, picture frames, table frames, etc.), but that essentially they all were
manipulated in the same ways.  We will learn some additional ways to work with these objects in this handout,
as well as noting other ways you can customize publications to make your document truly your own.

Tools Part Two
Recall that the buttons running down the left-hand side of the screen are object tools which allow us to create
frames.  We discussed six of these in Publisher 2000: Introduction (dwb03):  the Pointer Tool, the Text Tool,
the Picture Tool, the Clip Art Tool, the Table Tool, and the Word Art Tool.  We now move on to discuss the
remaining tools, though they work in much the same way as these first six did.

Line Tool

The Line Tool allows you to draw lines.  As with our other tools, we create lines by first clicking on
the Line Tool button, and then positioning our pointer (now in the form of a crosshair) on the page
where we want to begin drawing.  Click and hold to lay down one endpoint of the line; wherever you now drag
the mouse, a line stretches out to meet the crosshair.  Position this crosshair to indicate where the other
endpoint of the line should go and release the mouse button.  Your newly formed line has handles at both ends,
just as our frames did.  As before, this indicates that the line can be deleted, copied, or moved, as well as
formatted.  To draw "straight" lines (at some increment of 45 degrees), hold the Shift  key down as you drag out
the line.

Oval Tool

This tool allows you to draw ovals.  To draw an oval, select the Oval Tool with the button and click
and drag to draw in the same way you did with the Line Tool.  The only appreciable difference in
drawing ovals is that they will have more handles, just as frames did.  To constrain your drawing to perfect
circles, hold down the Shift  key while drawing the oval.

Box Tool

The Box Tool creates rectangles.  Click on the Box Tool to select it and then click and hold once more
on the page; drag to draw a box the size you want and release the mouse button.  Like ovals, rectangle
objects have both corner handles and side handles.  To draw perfect squares with the Box Tool, simply hold
down the Shift  key while you draw.

Custom Shapes Tool

While the creative person can make some pretty impressive pictures just using graphic tools like those
above, the rest of us will be glad to know that Publisher provides more graphic tools for more
interesting shapes.  The Custom Shapes Tool allows you to draw arrows, chevrons and even lightning bolts in
the same way we drew ovals and boxes.  Click on the Custom Shapes tool; a menu of different shapes will
appear.
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To begin drawing, click on the shape you want to draw and then position your pointer
on the page where you want to start drawing.  You will notice the pointer has become
the familiar crosshair; draw by dragging as we did with the other tools.  The Shift
key once again constrains your drawings in some way.  Some of these shapes may
present you with additional handles other than those we have seen thus far.  For
example, the chevron tool features an additional handle that you can click and hold on
to change the width of the chevron.

Insert Objects Command
Besides creating your own text and graphics objects with the tools we have used thus far, you can also insert
objects you have created with other programs that support Microsoft's Object Linking and Embedding (OLE)
technology.  To insert an OLE object into your document (which can include sounds and movie clips), go to the
Insert menu and choose Object….  Choose one of the programs listed to insert a file of that type, and
indicate Create New or Create from File, if you already have the sound file or whatever to include.  You
will be prompted to create a new object or locate a file whose contents you want to insert into the document.
You can also click the Link box to have a link maintained between the original file and the one embedded in
your publication so changes to the former will be reflected in the latter.  Alternatively, you can insert other files
into your document by choosing the Insert menu, then clicking Text  Fi le . . . , Picture.. . , or Object.. . .

Color, Borders and Shadows
Once you have created drawing objects with the tools above, whether they be ovals, lines or
chevrons, you can then jazz them up with color, borders and shadows.  Click on the object to
select it, and then choose one of the three buttons from the rightmost side of the
Format Toolbar.  The first is the Fil l  Color  button, which allows you to specify a
fill color, so that instead of a hollow oval hoop your drawing object can be an oval
filled with Carolina blue or fire engine red; your choices may be first restricted to
colors from your color scheme but you can ask to see More Colors  .  .  .  .  The
Line Color  button allows you to specify a different color for the border of the
object. The Line/Border Style button next to it allows you to create objects with
dashed lines for borders or thicker lines.

Manipulating Objects
We learned several ways of manipulating objects and the frames that hold them in the Introduction (dwb03)
handout.  Here we discuss several other important ways to manage objects which are used in most applications
as well as Publisher.

Layering

One important consideration when working with objects in most programs is the concept of layering.  Every
object created occupies a layer; specifically, the topmost one.  So as you create objects, you are creating more
layers on top of older layers, and should you move objects so that they overlap, later objects may obstruct
objects you created earlier.  Often you may want part of an object to obscure part of another, but other times
you will want to maneuver them so that both are visible.  For this we will need the Arrange menu.  Notice
the second section of this menu has four commands:  Bring to Front, Bring Forward, Send Backward,
and Send to Back.  To reorder the objects' layers in your publication, first click on the object you want to
manipulate.  This should bring up the object's handles to indicate you have selected it.  Now you can click on
the Arrange menu and then one of the four layering commands to reposition it.  Bring to Front will bring
the selected object to the topmost layer, regardless of how long ago it was created.  Conversely, Send to Back
will send the selected object to the back of all objects on the page.  You can also move the objects forward or
backward one layer at a time with Bring Forward and Send Backward, respectively.  Learning to properly
layer objects is an important skill in any drawing program.
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Grouping

Another useful tool in drawing programs is the ability to treat several objects as one.  We were briefly exposed
to this concept in the previous handout when we discussed the Design Gallery, which inserted preformatted
quotes, dividers, sidebars and other objects into our publication which were in fact made up of several smaller
objects.

To group several objects, you must first select them.  You can select an object by simply clicking on it to
reveal its handles, but when we click on another object it is selected and the first object is deselected.  To select
additional objects beyond the first, hold down the Shift  key while clicking on additional objects.  That is, click
on the first object you want to select and then Shift-click on other objects you want to add to the selection.
Their handles should appear as well.

At this point you can manipulate them as a group.  Pressing Delete
will delete all of the selected objects, choosing Copy  will copy all of
the selected objects, dragging one object moves them all as a group,
etc.  However, as soon as you select some object with a regular click
(not by Shift-clicking), these objects will no longer behave as a
group.  To treat them as one group until you decide to separate them,
select the objects as above and then select Group Objects from the
Arrange menu.  Each of the objects' individual handles should be
replaced by one set; at this point Publisher treats the group as one
great big object, even if you select another object, and will continue
to do so until you again select the grouped object and select
Ungroup Objects from the Arrange menu.  You can accomplish
the same thing by using the Group/Ungroup Object button in the
lower right-hand corner of the selected group (it looks like
interlocking puzzle pieces).  Clicking on this button while the pieces
look interlocked will ungroup the objects (separating them back into
their component objects), while clicking when the pieces are apart
will regroup them into one big object.

Design Gallery Revisited

Now that we know how to make our own groups of objects like those we inserted into our documents by means
of the Design Gallery tool, we can enter our own great designs into the Design Gallery for later use.  After
grouping objects with the Group Objects command, select the Insert menu and then choose the Add
Selection to Design Gallery.  .  .  command.  Now you can pull up that nifty logo you made in any
Publisher document you are working on!

Lining Up and Nudging Objects

You might want to nudge an object just a bit, and dragging it with the mouse might move it farther than you
had intended.  For this, you can click on Arrange and choose the Nudge Objects.  .  .  command, then
specify in what direction and how far you want to move the object.  You can also nudge objects by holding
down the ALT key and pressing one of the arrow keys. You might also want to line up several objects quickly
so that their edges are flush without having to do it manually.  This is also easily accomplished by selecting a
group of objects (in the same way we did before grouping them, by Shift-clicking) and then selecting the Align
Objects .  .  .  command, again from the Arrange menu.

Rotating and Flipping Objects

You might want your address text frame turned on its side or your lightning bolt graphic rotated 45 degrees.
This is possible through the Rotate/Flip  submenu of the Arrange menu.  Choosing Rotate Left will
rotate a selected object 90 degrees counterclockwise, while selecting Rotate Right  will spin the object 90
degrees clockwise.  Choosing Custom Rotate.  .  .  allows you to choose some other degree of rotation.
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You may also want to flip an object along its X or Y axis to mirror it.  To do this, simply click on the object
you want to flip and select either the Flip Vertically  or Flip Horizontally  command from the
Rotate/Flip  submenu.

Using Guides

A way to make you work easier is to utilize guides to help you line up objects.  These include the margins you
are probably used to from most other programs, but also column guides or other guides you designate.  Objects
you drag will automatically adjust to guides as long as you have this option selected from the Tools  menu.
You can create a horizontal or vertical guide line by pointing at the appropriate ruler and holding down the Shift
key.  Now click and drag to produce a guide line that you can drag onto the page area.  Once you have placed
guides in this way, you can Shift-drag them to a new location.

You can also add these guides by clicking on the Arrange
menu, then by clicking on the Ruler Guides submenu, and
finally by clicking on Add a Horizontal Ruler Guide or
Add a Vertical Ruler Guide.  You can rid yourself of all
these guides by selecting Clear All Ruler Guides.

If you need evenly spaced guides, such as with margins or
perhaps you want a three-column newsletter with evenly spaced
columns, then you will probably instead want to choose
Layout Guides. .  .  from the Arrange menu.  This will
bring up the Layout Guides dialog, which allows you to specify
both margin guides and row and column guides which will be
evenly spaced.

Custom Text Wrapping
We noted in the Introduction (dwb03) handout that graphics could be dragged onto text frames and that the text
would automatically wrap around the graphic frame.  We also saw that we could instead have the text wrap to
the image itself, instead of its frame, if we wanted to eliminate some white space around the object.  This
wrapping can also be edited if, for whatever reason, you are not happy with Publisher's boundaries.  To do this,
select the picture or clip art.  Then, change from Wrap Text to Frame to Wrap Text to Picture on the
Formatting toolbar. Once you have changed to Wrap Text to Picture,
choose Edit Irregular Wrap from the Format menu.  Handle-like
points will appear along the outside of the image, which you can click
and hold on to drag to new locations.  As you do so, the boundaries of
the wrap also change.  Think of the text wrap this way:  there is a fence
which text cannot get into, so it has to wrap around.  When text wraps
around the frame, the fenceposts of this fence are simply the handles of
the picture frame.  But when you choose to wrap the text to the image
itself, the fence tightens to just outside the image.  When you click on
the Edit Irregular Wrap button you can drag the fenceposts to any
location you want.

Text Formatting and Styles
As with word processing programs you might have used, text is formatted by
first highlighting the text within a frame that you want to format, and then
applying formatting options either by means of the Format Toolbar or by
clicking on the Format menu and then choosing Font .  .  . , Line
Spacing.  .  .  or Tabs.  .  . .   Such commands present you with dialog boxes
that allow you to preview text formatting before applying it.
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You can also apply fancy effects such as drop caps (those big letters that start out fairy tales) by selecting the
Drop Cap. .  .  command from the same menu.  This allows you to specify what sort of drop cap you want
and how many lines tall it should be.

Once you have done all this fancy text formatting, you may find yourself wishing you could quickly
apply the same formatting over and over again.  This can be accomplished by means of the Format
Painter.  To use the Format Painter, select some text that has all the character formatting you want to
apply to another set of text.  Then click on the Format Painter button on the toolbar.  Your pointer should now
have a little paint brush next to it; click on and drag over some text and you will "paint" the formatting of your
example text onto the new text.

Another more powerful way of accomplishing this is to define a text style.  This allows you to quickly apply
character and paragraph formatting quickly but also allows you to redefine a style so that all the text of that style
changes instantly to match your new specifications.  It works like this:  once you have formatted some text and
you would like to repeatedly use its format, go to the Format menu and choose the Text  Sty le .  .  .
command.  You will be presented with a dialog box; one of its options is to create a text style.  Choose this
option, and you will be presented with another
dialog box like the one to the right.  You are to
name the new style and specify any formatting
options you would like your text to have; a
preview is provided in the lower right-hand corner.
Once you have specified this new text style, it
will show up in the Text Style  menu on the
Format Toolbar (the leftmost one).  You can
now highlight text and choose your newly-defined
text style from the Text Style  menu to have the
text instantly conform to the definitions of the
text style.  Should you change your mind about what your text style should look like, simply go back to the
Text  Sty le .  .  .  command and choose to change an existing style.  Once you have made your changes, all text
in your document that has been defined as that style will immediately pick up the changes you specified.

The Background
Finally, we should note Publisher's background, which is where you will place things that you want to repeat
on every page, such as headers or page numbers.  To work on the background, go to the View  menu and choose
Go To Background.  Objects you create here (or paste here, if you have already created them) will appear on
every page unless you indicate otherwise.  You can get back to working on page-specific items by returning to
the View  menu and choosing Go To Foreground.  Some things you might want to do with the background
include the following:

Page Numbers

You will of course want to number your pages, but to do so you must place the numbers in the background.
Go to the background, then select Page Numbers from the Insert menu.  If you are not viewing the
background when you try to insert page numbers, it will fail, but Publisher will remind you to go to the
background first.

Watermarks

Perhaps you are interested in putting some sort of text (such as "DRAFT" or "TOP SECRET") or some picture
or logo in gray in the background.  To do this, make a picture frame or a WordArt frame once you have gone to
the background, and you can create a recurring watermark.

Hiding Background Objects on Certain Pages

It might be the case that you want recurring headers, page numbers or watermarks on some pages, but not on
others.  Not to worry--it is simple to suppress background objects for individual pages.  Simply go to the page
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where you want to suppress the background objects, click on the View  menu, and choose Ignore
Background.  Background objects now will not show up on this page.  To toggle them back on, choose this
option a second time.  Note that this is an all-or-nothing proposition; either all background objects are
displayed, or none of them are.
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